# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\d+\.\d+)\.([1-9])/\1.0\2/gm;t' <<< "1.01.1
1.01.2
1.01.3
1.02.1
1.02.01"