import re
regex = re.compile(r"^(\d+\.\d+)\.([1-9])", flags=re.MULTILINE)
test_str = ("1.01.1\n"
"1.01.2\n"
"1.01.3\n"
"1.02.1\n"
"1.02.01")
subst = "\\1.0\\2"
result = regex.sub(subst, test_str)
if result:
print(result)