import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+\\.\\d+)\\.([1-9])";
final String string = "1.01.1\n"
+ "1.01.2\n"
+ "1.01.3\n"
+ "1.02.1\n"
+ "1.02.01";
final String subst = "\\1.0\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}