#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\d+\.\d+)\.([1-9])"
Local $sString = "1.01.1" & @CRLF & _
"1.01.2" & @CRLF & _
"1.01.3" & @CRLF & _
"1.02.1" & @CRLF & _
"1.02.01"
Local $sSubst = "\1.0\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)