using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+\.\d+)\.([1-9])";
string substitution = @"\1.0\2";
string input = @"1.01.1
1.01.2
1.01.3
1.02.1
1.02.01";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}