$re = '/^(\d+\.\d+)\.([1-9])/m';
$str = '1.01.1
1.01.2
1.01.3
1.02.1
1.02.01';
$subst = "\1.0\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;