# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.* - (.*) - .*.(mp4)/$1.$2/g;t' <<< "8teenBoy (Helix Studios) - Testing the Tutor - Trevor Harris & Julian Bell [720p].mp4"