const regex = /.* - (.*) - .*.(mp4)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.* - (.*) - .*.(mp4)', 'g')
const str = `8teenBoy (Helix Studios) - Testing the Tutor - Trevor Harris & Julian Bell [720p].mp4`;
const subst = `$1.$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);