#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".* - (.*) - .*.(mp4)"
Local $sString = "8teenBoy (Helix Studios) - Testing the Tutor - Trevor Harris & Julian Bell [720p].mp4"
Local $sSubst = "$1.$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)