import Foundation
let pattern = #".* - (.*) - .*.(mp4)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"8teenBoy (Helix Studios) - Testing the Tutor - Trevor Harris & Julian Bell [720p].mp4"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1.$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)