// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".* - (.*) - .*.(mp4)").unwrap();
let string = "8teenBoy (Helix Studios) - Testing the Tutor - Trevor Harris & Julian Bell [720p].mp4";
let substitution = "$1.$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}