#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\S+)\t(\S+)\t(\S+)$"
Local $sString = "AAAA BBBBBBBBBBBBBBB CCCC"
Local $sSubst = "$1_$3 $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)