package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\S+)\t(\S+)\t(\S+)$`)
var str = `AAAA BBBBBBBBBBBBBBB CCCC`
var substitution = "$1_$3 $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}