re = /^(\S+)\t(\S+)\t(\S+)$/m
str = 'AAAA BBBBBBBBBBBBBBB CCCC'
subst = '$1_$3 $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result