const regex = /^(\S+)\t(\S+)\t(\S+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\S+)\\t(\\S+)\\t(\\S+)$', 'gm')
const str = `AAAA BBBBBBBBBBBBBBB CCCC`;
const subst = `$1_$3 $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);