$re = '/^(\S+)\t(\S+)\t(\S+)$/m';
$str = 'AAAA BBBBBBBBBBBBBBB CCCC';
$subst = "$1_$3 $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;