import Foundation
let pattern = #"^(\S+)\t(\S+)\t(\S+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"AAAA BBBBBBBBBBBBBBB CCCC"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1_$3 $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)