use strict;
my $str = 'AAAA BBBBBBBBBBBBBBB CCCC';
my $regex = qr/^(\S+)\t(\S+)\t(\S+)$/mp;
my $subst = '$1_$3 $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";