using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\S+)\t(\S+)\t(\S+)$";
string substitution = @"$1_$3 $2";
string input = @"AAAA BBBBBBBBBBBBBBB CCCC";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}