#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<code name=["\\]+(.*?)["\\]+>(.*?)<\\\/code>"
Local $sString = "<div>Какой-то код <code name=\"c+++\">" & @CRLF & _
"void main(){ " & @CRLF & _
" cout<<\"heelo world\";" & @CRLF & _
" class A{" & @CRLF & _
" char *name;" & @CRLF & _
" A(char *n):namae(n);" & @CRLF & _
" } " & @CRLF & _
"}<\/code> Конец первого блока кода // <b> СТРОКИ. </b><div>Все</div> " & @CRLF & _
"<code name="c++">" & @CRLF & _
"#include <iostream> " & @CRLF & _
"void print(char * msg){" & @CRLF & _
" cout<<msg;" & @CRLF & _
"<\/code>" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")