$re = '/<code name=["\\\\]+(.*?)["\\\\]+>(.*?)<\\\\\/code>/s';
$str = '<div>Какой-то код <code name=\\"c+++\\">
void main(){
cout<<\\"heelo world\\";
class A{
char *name;
A(char *n):namae(n);
}
}<\\/code> Конец первого блока кода // <b> СТРОКИ. </b><div>Все</div>
<code name="c++">
#include <iostream>
void print(char * msg){
cout<<msg;
<\\/code>
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);