import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<code name=[\"\\\\]+(.*?)[\"\\\\]+>(.*?)<\\\\\\/code>";
final String string = "<div>Какой-то код <code name=\\\"c+++\\\">\n"
+ "void main(){ \n"
+ " cout<<\\\"heelo world\\\";\n"
+ " class A{\n"
+ " char *name;\n"
+ " A(char *n):namae(n);\n"
+ " } \n"
+ "}<\\/code> Конец первого блока кода // <b> СТРОКИ. </b><div>Все</div> \n"
+ "<code name=\"c++\">\n"
+ "#include <iostream> \n"
+ "void print(char * msg){\n"
+ " cout<<msg;\n"
+ "<\\/code>\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}