using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<code name=[""\\]+(.*?)[""\\]+>(.*?)<\\\/code>";
string input = @"<div>Какой-то код <code name=\""c+++\"">
void main(){
cout<<\""heelo world\"";
class A{
char *name;
A(char *n):namae(n);
}
}<\/code> Конец первого блока кода // <b> СТРОКИ. </b><div>Все</div>
<code name=""c++"">
#include <iostream>
void print(char * msg){
cout<<msg;
<\/code>
}";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}