const regex = /<code name=["\\]+(.*?)["\\]+>(.*?)<\\\/code>/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<code name=["\\\\]+(.*?)["\\\\]+>(.*?)<\\\\\\\/code>', 'gs')
const str = `<div>Какой-то код <code name=\\"c+++\\">
void main(){
cout<<\\"heelo world\\";
class A{
char *name;
A(char *n):namae(n);
}
}<\\/code> Конец первого блока кода // <b> СТРОКИ. </b><div>Все</div>
<code name="c++">
#include <iostream>
void print(char * msg){
cout<<msg;
<\\/code>
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}