import Foundation
let pattern = #"<code name=["\\]+(.*?)["\\]+>(.*?)<\\\/code>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = ##"""
<div>Какой-то код <code name=\"c+++\">
void main(){
cout<<\"heelo world\";
class A{
char *name;
A(char *n):namae(n);
}
}<\/code> Конец первого блока кода // <b> СТРОКИ. </b><div>Все</div>
<code name="c++">
#include <iostream>
void print(char * msg){
cout<<msg;
<\/code>
}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)