use strict;
my $str = '<div>Какой-то код <code name=\\"c+++\\">
void main(){
cout<<\\"heelo world\\";
class A{
char *name;
A(char *n):namae(n);
}
}<\\/code> Конец первого блока кода // <b> СТРОКИ. </b><div>Все</div>
<code name="c++">
#include <iostream>
void print(char * msg){
cout<<msg;
<\\/code>
}';
my $regex = qr/<code name=["\\]+(.*?)["\\]+>(.*?)<\\\/code>/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}