re = /<code name=["\\]+(.*?)["\\]+>(.*?)<\\\/code>/
str = '<div>Какой-то код <code name=\\"c+++\\">
void main(){
cout<<\\"heelo world\\";
class A{
char *name;
A(char *n):namae(n);
}
}<\\/code> Конец первого блока кода // <b> СТРОКИ. </b><div>Все</div>
<code name="c++">
#include <iostream>
void print(char * msg){
cout<<msg;
<\\/code>
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end