package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\-?\d{1,3}(?:(?:\,\d{3})|\d)*(?:\.\d+)?(?:[Ee\^]\d+)?\ *)+$`)
var str = `100
2000
45,305,201,45,2506
-10,000,000.424
2015 4 4
592 -59285 6e4
204E34
40245.243e
234ggff
Hello, World! 4
261
1293712938712938172938172391287319237192837329
3.23e4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}