import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\-?\\d{1,3}(?:(?:\\,\\d{3})|\\d)*(?:\\.\\d+)?(?:[Ee\\^]\\d+)?\\ *)+$";
final String string = "100\n"
+ "2000\n"
+ "45,305,201,45,2506\n"
+ "-10,000,000.424\n"
+ "2015 4 4\n"
+ "592 -59285 6e4\n"
+ "204E34\n"
+ "40245.243e\n"
+ "234ggff\n"
+ "Hello, World! 4\n"
+ "261\n"
+ "1293712938712938172938172391287319237192837329\n"
+ "3.23e4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}