import re
regex = re.compile(r"^(\-?\d{1,3}(?:(?:\,\d{3})|\d)*(?:\.\d+)?(?:[Ee\^]\d+)?\ *)+$", flags=re.MULTILINE)
test_str = ("100\n"
"2000\n"
"45,305,201,45,2506\n"
"-10,000,000.424\n"
"2015 4 4\n"
"592 -59285 6e4\n"
"204E34\n"
"40245.243e\n"
"234ggff\n"
"Hello, World! 4\n"
"261\n"
"1293712938712938172938172391287319237192837329\n"
"3.23e4")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")