const regex = new RegExp('^(\\-?\\d{1,3}(?:(?:\\,\\d{3})|\\d)*(?:\\.\\d+)?(?:[Ee\\^]\\d+)?\\ *)+$', 'gm')
const str = `100
2000
45,305,201,45,2506
-10,000,000.424
2015 4 4
592 -59285 6e4
204E34
40245.243e
234ggff
Hello, World! 4
261
1293712938712938172938172391287319237192837329
3.23e4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}