use strict;
my $str = '100
2000
45,305,201,45,2506
-10,000,000.424
2015 4 4
592 -59285 6e4
204E34
40245.243e
234ggff
Hello, World! 4
261
1293712938712938172938172391287319237192837329
3.23e4';
my $regex = qr/^(\-?\d{1,3}(?:(?:\,\d{3})|\d)*(?:\.\d+)?(?:[Ee\^]\d+)?\ *)+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}