# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[([^\[\]]++|(?R))*+\]/null/;t' <<< "56380
[ Close_f8237_t8237.000 ]
56381
[ Close_f8237_t8237.000 ]
56382"