import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[([^\\[\\]]++|(?R))*+\\]";
final String string = "56380\n"
+ "[ Close_f8237_t8237.000 ]\n"
+ "56381\n"
+ "[ Close_f8237_t8237.000 ]\n"
+ "56382";
final String subst = "null";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}