re = /\[([^\[\]]++|(?R))*+\]/
str = '56380
[ Close_f8237_t8237.000 ]
56381
[ Close_f8237_t8237.000 ]
56382'
subst = 'null'
result = str.sub(re, subst)
# Print the result of the substitution
puts result