import Foundation
let pattern = #"\[([^\[\]]++|(?R))*+\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
56380
[ Close_f8237_t8237.000 ]
56381
[ Close_f8237_t8237.000 ]
56382
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"null"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}