use strict;
my $str = '56380
[ Close_f8237_t8237.000 ]
56381
[ Close_f8237_t8237.000 ]
56382';
my $regex = qr/\[([^\[\]]++|(?R))*+\]/p;
my $subst = 'null';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";