package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[([^\[\]]++|(?R))*+\]`)
var str = []byte(`56380
[ Close_f8237_t8237.000 ]
56381
[ Close_f8237_t8237.000 ]
56382`)
var substitution = []byte("null")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}