// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[([^\[\]]++|(?R))*+\]").unwrap();
let string = "56380
[ Close_f8237_t8237.000 ]
56381
[ Close_f8237_t8237.000 ]
56382";
let substitution = "null";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}