using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\n|\r|\t|\0|^\s+|\s+$|[\b])";
string substitution = @"";
string input = @" no trim is required
as
bad characters like null, tab, newline, backspace
et.c would be removed substitution is empty string.
wohoo
remove multiline switch in production";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}