# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\n|\r|\t|\0|^\s+|\s+$|[\b])"
test_str = (" no trim is required\n"
"as\n"
" \n"
"bad characters like null, tab, newline, backspace\n\n"
"et.c would be removed substitution is empty string.\n\n"
" wohoo \n"
"remove multiline switch in production")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.