use strict;
my $str = ' no trim is required
as
bad characters like null, tab, newline, backspace
et.c would be removed substitution is empty string.
wohoo
remove multiline switch in production';
my $regex = qr/(\n|\r|\t|\0|^\s+|\s+$|[\b])/imp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";