import Foundation
let pattern = #"(\n|\r|\t|\0|^\s+|\s+$|[\b])"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
no trim is required
as
bad characters like null, tab, newline, backspace
et.c would be removed substitution is empty string.
wohoo
remove multiline switch in production
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)