const regex = /(\n|\r|\t|\0|^\s+|\s+$|[\b])/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\n|\\r|\\t|\\0|^\\s+|\\s+$|[\\b])', 'gim')
const str = ` no trim is required
as
bad characters like null, tab, newline, backspace
et.c would be removed substitution is empty string.
wohoo
remove multiline switch in production`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);