// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)(\n|\r|\t|\0|^\s+|\s+$|[\b])").unwrap();
let string = " no trim is required
as
bad characters like null, tab, newline, backspace
et.c would be removed substitution is empty string.
wohoo
remove multiline switch in production";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}