import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\n|\\r|\\t|\\0|^\\s+|\\s+$|[\\b])";
final String string = " no trim is required\n"
+ "as\n"
+ " \n"
+ "bad characters like null, tab, newline, backspace\n\n"
+ "et.c would be removed substitution is empty string.\n\n"
+ " wohoo \n"
+ "remove multiline switch in production";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}