using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"D:\/\(!\)PLAYING\/(.*.mp3)";
string substitution = @"C:\\Music\\(!)PLAYING\\";
string input = @"D:/(!)PLAYING/157490069/c8732d4/file_name.mp3
D:/(!)PLAYING/123123/2d4/file_name.mp3
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}