use strict;
my $str = 'D:/(!)PLAYING/157490069/c8732d4/file_name.mp3
D:/(!)PLAYING/123123/2d4/file_name.mp3
';
my $regex = qr/D:\/\(!\)PLAYING\/(.*.mp3)/p;
my $subst = 'C:\\\\Music\\\\(!)PLAYING\\\\';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";