import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "D:\\/\\(!\\)PLAYING\\/(.*.mp3)";
final String string = "D:/(!)PLAYING/157490069/c8732d4/file_name.mp3\n"
+ "D:/(!)PLAYING/123123/2d4/file_name.mp3\n";
final String subst = "C:\\\\Music\\\\(!)PLAYING\\\\";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}