const regex = /D:\/\(!\)PLAYING\/(.*.mp3)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('D:\\\/\\(!\\)PLAYING\\\/(.*.mp3)', '')
const str = `D:/(!)PLAYING/157490069/c8732d4/file_name.mp3
D:/(!)PLAYING/123123/2d4/file_name.mp3
`;
const subst = `C:\\Music\\(!)PLAYING\\`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);